SKR1.3 mit Watterott TMC2209 / war: Hilfe, brauche neues Board

janser123
Neuling
Beiträge: 2
Registriert: Fr 4. Okt 2019, 17:25
Hat sich bedankt: 0
Danksagung erhalten: 0

Re: SKR1.3 mit Watterott TMC2209 / war: Hilfe, brauche neues Board

#51

Beitrag von janser123 » Sa 19. Okt 2019, 15:40

Moin zusammen,

ich habe ein SKR 1.3 mit den TMC 2209 von Watterot uns setze Klipper ein.
Ich bekomme die Treiber nicht per UART angesprochen.
Ich hab alles nach der Anleitung von borg oben gemacht bekomme von Klipper aber immer nur
"Unable to read tmc uart 'stepper_x' register IFCNT"

Hier einmal die Bilder von den Jumper auf dem Board für die X Achse
WhatsApp Image 2019-10-19 at 15.37.02.jpeg
Hier ein BIld vom Jumper(abgekniffener Pin und Lötbrücke)
WhatsApp Image 2019-10-19 at 15.36.57.jpeg
Hier die Konfiguration in Klipper
[tmc2209 stepper_x]
uart_pin: P1.17
microsteps: 16
run_current: 0.800
hold_current: 0.500
stealthchop_threshold: 250
driver_SGTHRS: 0
#diag_pin:


Übersehe ich etwas?
Hat einer eine Idee wo mein Fehler ist.

Benutzeravatar
Nico740
Unterstützer
Beiträge: 431
Registriert: So 14. Apr 2019, 14:20
Wohnort: Nottuln
Drucker: Anet A8 Marlin 2.X
Slicer: Cura
Hat sich bedankt: 13 Mal
Danksagung erhalten: 1 Mal

#52

Beitrag von Nico740 » So 20. Okt 2019, 14:59

Also wenn ich das richtig sehe hast Du, zumindest bei dem Treiber auf dem Bild, nicht den UART-Jumper Y gesetzt wo aber ein TMC draufsteckt, sondern nur bei X, dort steckt aber keiner...

janser123
Neuling
Beiträge: 2
Registriert: Fr 4. Okt 2019, 17:25
Hat sich bedankt: 0
Danksagung erhalten: 0

#53

Beitrag von janser123 » So 20. Okt 2019, 20:31

Ja das siehst du richtig ich versuche gerade erstmal einen Treiber zum laufen zu kriegen.
EDIT1: Ok ich habe den Drucker gerade nochmal angeschmissen und siehe da er erkennt den X Steppertreiber, also hab ich etwas weiter rumprobiert und habe auch Z1 zum laufen bekommen.

Y, Extruder und Z2 wollen trotzdem einfach nicht.
Ich kann die Treiber untereinander tauschen der Fehler bleibt aber immer bei Y,E und Z2, ich vermute mein Board hat eine Macke.
Hat jemand eine Idee wie ich das Board noch testen könnte ?

Benutzeravatar
Nico740
Unterstützer
Beiträge: 431
Registriert: So 14. Apr 2019, 14:20
Wohnort: Nottuln
Drucker: Anet A8 Marlin 2.X
Slicer: Cura
Hat sich bedankt: 13 Mal
Danksagung erhalten: 1 Mal

#54

Beitrag von Nico740 » Mo 21. Okt 2019, 08:01

Aber Du hast bei jedem Treiber auch auf dem Board den UART-Jumper wie bei X gesetzt?

Benutzeravatar
riff-raff
Moderator
Beiträge: 912
Registriert: Do 19. Apr 2018, 14:35
Wohnort: Leipzig
Drucker: ANET A8, CoreXY
Slicer: Prusa Slic3r
Firmware: Marlin 2.0-bugfix
CAD - Software: F360, Inv, SW
Hat sich bedankt: 34 Mal
Danksagung erhalten: 83 Mal

#55

Beitrag von riff-raff » Mo 21. Okt 2019, 18:47

SKR 1.3 Handbuch

In Sektion 3.3 wird die UART-Beschaltung hinreichend dokumentiert.

Bild

Pins:
Unbenannt.JPG
Unbenannt.JPG (59.05 KiB) 62 mal betrachtet
Quelle: BIQU SKR1.3 schematic diagram (2019-10-21)

Config:

Code: Alles auswählen

[tmc2209 stepper_x]
uart_pin: P1.17
[tmc2209 stepper_y]
uart_pin: P1.15
[tmc2209 stepper_z]
uart_pin: P1.10
[tmc2209 stepper_e0]
uart_pin: P1.8
[tmc2209 stepper_e1]
uart_pin: P1.1
E0 sollte Z2 entsprechen wenn ich recht in der Annahme gehe? Wie schaut deine Config jetzt aus?
Chaos is found in greatest abundance wherever order is being sought.
It always defeats order, because it is better organized.
Terry Pratchett

Antworten
  • Vergleichbare Themen
    Antworten
    Zugriffe
    Letzter Beitrag