Hinweis: Arduino 1.8.6 und Marlin inkompatibel

Diskussionen Rund um die Firmware eurer 3D Druckerer wie Marlin, Skynet, Repetier etc.
Antworten
oakdesign
Bronze - Status
Beiträge: 78
Registriert: Fr 7. Jul 2017, 15:26
Hat sich bedankt: 2 Mal
Danksagung erhalten: 31 Mal

Hinweis: Arduino 1.8.6 und Marlin inkompatibel

Beitrag von oakdesign » Mo 3. Sep 2018, 11:58

Kurzer Hinweis. Die neuste Version von Arduino 1.8.6 hat einen Bug der beim versuch Marlin zu kompilieren zu Fehlern führt.
Das liegt an der Behandlung von Kommentaren im Code.
Folgende lösungsansätze:
Arduino 1.8.5 nutzen https://www.arduino.cc/en/Main/OldSoftw ... s#previous
Alternative IDE Wie z.B Paltformio nutzen https://platformio.org/platformio-die
Marlin config nutzen https://github.com/akaJes/marlin-config

Arduino 1.8.6 nutzen und jeden Kommentar der als Fehler ausgegeben wird löschen. Je nach Konfiguaration können das en paar wenige (3-4) oder halt auch mehr sein sein.
gleicher Sketch
mit Marlin 1.1.9 kompiliert mit 1.8.5
Bild

mit 1.8.6
Bild

Gruss Richard



Medi36
New - Member
Beiträge: 6
Registriert: Mi 12. Sep 2018, 10:14
Wohnort: z.Z. Spanien
Drucker: ANET A8

Beitrag von Medi36 » So 16. Sep 2018, 11:35

Hola oakdesing
Gibt mittlerweile die IDE 1.8.7 die geht hatte das Problem vorher mit der Marlin bugfix 2.0.x
die wird jetzt ohne Probleme kompiliert.
Gruß
Medi36



Für registrierte User wird diese Werbung ausgeblendet !
oakdesign
Bronze - Status
Beiträge: 78
Registriert: Fr 7. Jul 2017, 15:26
Hat sich bedankt: 2 Mal
Danksagung erhalten: 31 Mal

Beitrag von oakdesign » So 16. Sep 2018, 17:31

Korrekt in der 1.8.7 ist der bug behoben. Für bugfix 2.0 verwende ich keine Arduino IDE da du damit nicht für 32 bit board kompilieren kannst

Gruss Richard



Für registrierte User wird diese Werbung ausgeblendet !
Benutzeravatar
th33xitus
Site - Moderator
Beiträge: 2262
Registriert: Sa 17. Dez 2016, 00:31
Drucker: Anet A8
Slicer: S3D / Slic3r PE
CAD - Software: Inventor
Hat sich bedankt: 114 Mal
Danksagung erhalten: 331 Mal

Beitrag von th33xitus » So 16. Sep 2018, 17:51

oakdesign hat geschrieben:
So 16. Sep 2018, 17:31
Für bugfix 2.0 verwende ich keine Arduino IDE da du damit nicht für 32 bit board kompilieren kannst
Wie meinste das denn?
Ich kompiliere seit Monaten mit der Beta 1.9.0 für mein Due damit.


Gebt bei jeglichen Problemen immer euren verwendeten Slicer + dessen Einstellungen, eure genutzte Firmware und etwaige Modifikationen vom Drucker an!


:idea: :!: Glossar - 3D-Druck-Begriffe :!: :idea:


Für registrierte User wird diese Werbung ausgeblendet !
oakdesign
Bronze - Status
Beiträge: 78
Registriert: Fr 7. Jul 2017, 15:26
Hat sich bedankt: 2 Mal
Danksagung erhalten: 31 Mal

Beitrag von oakdesign » So 16. Sep 2018, 22:21

th33xitus hat geschrieben:
So 16. Sep 2018, 17:51
oakdesign hat geschrieben:
So 16. Sep 2018, 17:31
Für bugfix 2.0 verwende ich keine Arduino IDE da du damit nicht für 32 bit board kompilieren kannst
Wie meinste das denn?
Ich kompiliere seit Monaten mit der Beta 1.9.0 für mein Due damit.
Ich meine damit die Stable Releases 1.8.x . Und meine Antwort bezog sich ja explizit auf die 1.8.7
Grundsätzlich bin ich selbst schon lange von Arduino IDE weg



Für registrierte User wird diese Werbung ausgeblendet !
Antworten
  • Vergleichbare Themen
    Antworten
    Zugriffe
    Letzter Beitrag